]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/clamav/clamav.mk
package/clamav: bump version to 0.98.6
[coffee/buildroot.git] / package / clamav / clamav.mk
1 ################################################################################
2 #
3 # clamav
4 #
5 ################################################################################
6
7 CLAMAV_VERSION = 0.98.6
8 CLAMAV_SITE = http://sourceforge.net/projects/clamav/files/clamav/$(CLAMAV_VERSION)
9 CLAMAV_LICENSE = GPLv2
10 CLAMAV_LICENSE_FILES = COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
11         COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.regex COPYING.sha256 \
12         COPYING.unrar COPYING.zlib
13 # clamav-0002-static-linking.patch touches configure.ac
14 CLAMAV_AUTORECONF = YES
15 CLAMAV_DEPENDENCIES = openssl zlib $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
16
17 # mmap cannot be detected when cross-compiling, needed for mempool support
18 CLAMAV_CONF_ENV = \
19         ac_cv_c_mmap_private=yes
20
21 CLAMAV_CONF_OPTS = \
22         --with-dbdir=/var/lib/clamav \
23         --with-openssl=$(STAGING_DIR)/usr \
24         --with-zlib=$(STAGING_DIR)/usr \
25         --disable-rpath \
26         --disable-clamuko \
27         --disable-clamav \
28         --disable-milter \
29         --disable-llvm \
30         --disable-clamdtop \
31         --enable-mempool
32
33 ifeq ($(BR2_PACKAGE_BZIP2),y)
34 CLAMAV_DEPENDENCIES += bzip2
35 # autodetection gets confused if host has bzip2, so force it
36 CLAMAV_CONF_ENV += \
37         ac_cv_libbz2_libs=-lbz2 \
38         ac_cv_libbz2_ltlibs=-lbz2
39 else
40 CLAMAV_CONF_OPTS += --disable-bzip2
41 endif
42
43 ifeq ($(BR2_PACKAGE_LIBXML2),y)
44 CLAMAV_CONF_OPTS += --with-xml=$(STAGING_DIR)/usr
45 CLAMAV_DEPENDENCIES += libxml2
46 else
47 CLAMAV_CONF_OPTS += --disable-xml
48 endif
49
50 ifeq ($(BR2_PACKAGE_LIBCURL),y)
51 CLAMAV_CONF_OPTS += --with-libcurl=$(STAGING_DIR)/usr
52 CLAMAV_DEPENDENCIES += libcurl
53 else
54 CLAMAV_CONF_OPTS += --without-libcurl
55 endif
56
57 ifeq ($(BR2_PACKAGE_LIBICONV),y)
58 CLAMAV_CONF_OPTS += --with-iconv
59 CLAMAV_DEPENDENCIES += libiconv
60 else
61 CLAMAV_CONF_OPTS += --without-iconv
62 endif
63
64 $(eval $(autotools-package))