]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/clamav/clamav.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / clamav / clamav.mk
1 ################################################################################
2 #
3 # clamav
4 #
5 ################################################################################
6
7 CLAMAV_VERSION = 0.100.0
8 CLAMAV_SITE = https://www.clamav.net/downloads/production
9 CLAMAV_LICENSE = GPL-2.0
10 CLAMAV_LICENSE_FILES = COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
11         COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
12         COPYING.unrar COPYING.zlib
13 CLAMAV_DEPENDENCIES = \
14         host-pkgconf \
15         libtool \
16         openssl \
17         zlib \
18         $(TARGET_NLS_DEPENDENCIES)
19 # 0003-m4-reorganization-libs-curl.m4-fix-curl-config-detec.patch
20 CLAMAV_AUTORECONF = YES
21
22 # mmap cannot be detected when cross-compiling, needed for mempool support
23 CLAMAV_CONF_ENV = \
24         ac_cv_c_mmap_private=yes \
25         have_cv_ipv6=yes
26
27 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
28 CLAMAV_CONF_OPTS = \
29         --with-dbdir=/var/lib/clamav \
30         --with-ltdl-include=$(STAGING_DIR)/usr/include \
31         --with-ltdl-lib=$(STAGING_DIR)/usr/lib \
32         --with-openssl=$(STAGING_DIR)/usr \
33         --with-zlib=$(STAGING_DIR)/usr \
34         --disable-zlib-vcheck \
35         --disable-rpath \
36         --disable-clamav \
37         --disable-fanotify \
38         --disable-milter \
39         --disable-llvm \
40         --disable-clamdtop \
41         --enable-mempool
42
43 ifeq ($(BR2_PACKAGE_BZIP2),y)
44 CLAMAV_DEPENDENCIES += bzip2
45 # autodetection gets confused if host has bzip2, so force it
46 CLAMAV_CONF_ENV += \
47         ac_cv_libbz2_libs=-lbz2 \
48         ac_cv_libbz2_ltlibs=-lbz2
49 else
50 CLAMAV_CONF_OPTS += --disable-bzip2
51 endif
52
53 ifeq ($(BR2_PACKAGE_JSON_C),y)
54 CLAMAV_CONF_OPTS += --with-libjson=$(STAGING_DIR)/usr
55 CLAMAV_DEPENDENCIES += json-c
56 else
57 CLAMAV_CONF_OPTS += --without-libjson
58 endif
59
60 ifeq ($(BR2_PACKAGE_LIBXML2),y)
61 CLAMAV_CONF_OPTS += --with-xml=$(STAGING_DIR)/usr
62 CLAMAV_DEPENDENCIES += libxml2
63 else
64 CLAMAV_CONF_OPTS += --disable-xml
65 endif
66
67 ifeq ($(BR2_PACKAGE_LIBCURL),y)
68 CLAMAV_CONF_OPTS += --with-libcurl=$(STAGING_DIR)/usr
69 CLAMAV_DEPENDENCIES += libcurl
70 else
71 CLAMAV_CONF_OPTS += --without-libcurl
72 endif
73
74 ifeq ($(BR2_PACKAGE_LIBICONV),y)
75 CLAMAV_CONF_OPTS += --with-iconv
76 CLAMAV_DEPENDENCIES += libiconv
77 else
78 CLAMAV_CONF_OPTS += --without-iconv
79 endif
80
81 ifeq ($(BR2_PACKAGE_PCRE),y)
82 CLAMAV_CONF_OPTS += --with-pcre=$(STAGING_DIR)/usr
83 CLAMAV_DEPENDENCIES += pcre
84 else
85 CLAMAV_CONF_OPTS += --without-pcre
86 endif
87
88 $(eval $(autotools-package))