]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/clamav/clamav.mk
package/clamav: bump version to 0.100.0
[coffee/buildroot.git] / package / clamav / clamav.mk
1 ################################################################################
2 #
3 # clamav
4 #
5 ################################################################################
6
7 CLAMAV_VERSION = 0.100.0
8 CLAMAV_SITE = https://www.clamav.net/downloads/production
9 CLAMAV_LICENSE = GPL-2.0
10 CLAMAV_LICENSE_FILES = COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
11         COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
12         COPYING.unrar COPYING.zlib
13 CLAMAV_DEPENDENCIES = \
14         host-pkgconf \
15         libtool \
16         openssl \
17         zlib \
18         $(TARGET_NLS_DEPENDENCIES)
19
20 # mmap cannot be detected when cross-compiling, needed for mempool support
21 CLAMAV_CONF_ENV = \
22         ac_cv_c_mmap_private=yes \
23         have_cv_ipv6=yes
24
25 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
26 CLAMAV_CONF_OPTS = \
27         --with-dbdir=/var/lib/clamav \
28         --with-ltdl-include=$(STAGING_DIR)/usr/include \
29         --with-ltdl-lib=$(STAGING_DIR)/usr/lib \
30         --with-openssl=$(STAGING_DIR)/usr \
31         --with-zlib=$(STAGING_DIR)/usr \
32         --disable-zlib-vcheck \
33         --disable-rpath \
34         --disable-clamav \
35         --disable-fanotify \
36         --disable-milter \
37         --disable-llvm \
38         --disable-clamdtop \
39         --enable-mempool
40
41 ifeq ($(BR2_PACKAGE_BZIP2),y)
42 CLAMAV_DEPENDENCIES += bzip2
43 # autodetection gets confused if host has bzip2, so force it
44 CLAMAV_CONF_ENV += \
45         ac_cv_libbz2_libs=-lbz2 \
46         ac_cv_libbz2_ltlibs=-lbz2
47 else
48 CLAMAV_CONF_OPTS += --disable-bzip2
49 endif
50
51 ifeq ($(BR2_PACKAGE_JSON_C),y)
52 CLAMAV_CONF_OPTS += --with-libjson=$(STAGING_DIR)/usr
53 CLAMAV_DEPENDENCIES += json-c
54 else
55 CLAMAV_CONF_OPTS += --without-libjson
56 endif
57
58 ifeq ($(BR2_PACKAGE_LIBXML2),y)
59 CLAMAV_CONF_OPTS += --with-xml=$(STAGING_DIR)/usr
60 CLAMAV_DEPENDENCIES += libxml2
61 else
62 CLAMAV_CONF_OPTS += --disable-xml
63 endif
64
65 ifeq ($(BR2_PACKAGE_LIBCURL),y)
66 CLAMAV_CONF_OPTS += --with-libcurl=$(STAGING_DIR)/usr
67 CLAMAV_DEPENDENCIES += libcurl
68 else
69 CLAMAV_CONF_OPTS += --without-libcurl
70 endif
71
72 ifeq ($(BR2_PACKAGE_LIBICONV),y)
73 CLAMAV_CONF_OPTS += --with-iconv
74 CLAMAV_DEPENDENCIES += libiconv
75 else
76 CLAMAV_CONF_OPTS += --without-iconv
77 endif
78
79 ifeq ($(BR2_PACKAGE_PCRE),y)
80 CLAMAV_CONF_OPTS += --with-pcre=$(STAGING_DIR)/usr
81 CLAMAV_DEPENDENCIES += pcre
82 else
83 CLAMAV_CONF_OPTS += --without-pcre
84 endif
85
86 $(eval $(autotools-package))