]> rtime.felk.cvut.cz Git - sojka/lightdm.git/blob - debian/rules
Warn users about the temporary nature of a guest session.
[sojka/lightdm.git] / debian / rules
1 #!/usr/bin/make -f 
2
3 LDFLAGS+=-Wl,--as-needed
4
5 %:
6         dh $@ --with quilt,autoreconf,translations --parallel
7
8 override_dh_autoreconf:
9         NOCONFIGURE=1 dh_autoreconf ./autogen.sh
10
11 # NOTE: Using GNOME for now, but we still need a proper configuration system
12 # See https://launchpad.net/bugs/799754
13 override_dh_auto_configure:
14         dh_auto_configure -- --with-greeter-user=lightdm --with-user-session=ubuntu --enable-gtk-doc
15
16 override_dh_auto_test:
17         #Disabled for now, are failing for some reason
18         #DEBUG=1 dh_auto_test || { cat tests/test-suite.log; exit 1; }
19
20 override_dh_install:
21         rm -r debian/tmp/usr/share/help/C/
22         # we do install pam through installpam and init through installinit
23         dh_install -X.a -X.la -Xpam.d -X'etc/init/lightdm.conf' --fail-missing
24         chmod +x debian/lightdm/usr/lib/lightdm/lightdm-greeter-session
25         chmod +x debian/lightdm/usr/lib/lightdm/guest-session-auto.sh
26
27 override_dh_installinit:
28         dh_installinit --no-start
29
30 override_dh_installpam:
31         dh_installpam
32         dh_installpam --name=lightdm-autologin
33         dh_installpam --name=lightdm-greeter
34         
35 override_dh_makeshlibs:
36         dh_makeshlibs -pliblightdm-gobject-1-0 -V'liblightdm-gobject-1-0 (>= 0.9.2)' -- -c4
37         dh_makeshlibs -Nliblightdm-gobject-1-0