]> rtime.felk.cvut.cz Git - sojka/debian/lightdm.git/blob - debian/patches/03_quit-plymouth.patch
* debian/patches:
[sojka/debian/lightdm.git] / debian / patches / 03_quit-plymouth.patch
1 Author: Yves-Alexis Perez <corsac@debian.org>
2 Description: quit plymouth instead of deactivating it
3 plymouth is quitted from the /etc/init.d/plymouth script, but it'll hang if
4 plymouth has been deactivated before, so just quit it for now.
5 Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=632737
6 Bug: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/799069
7 --- a/src/xserver-local.c
8 +++ b/src/xserver-local.c
9 @@ -142,7 +142,7 @@ xserver_local_new (void)
10              g_debug ("X server %s will replace Plymouth", xserver_get_address (XSERVER (self)));
11              self->priv->replacing_plymouth = TRUE;
12              self->priv->vt = active_vt;
13 -            plymouth_deactivate ();
14 +            plymouth_quit (FALSE);
15          }
16          else
17              g_debug ("Plymouth is running on VT %d, but this is less than the configured minimum of %d so not replacing it", active_vt, vt_get_min ());