]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/procps-ng/procps-ng.mk
procps-ng: security bump to version 3.3.15
[coffee/buildroot.git] / package / procps-ng / procps-ng.mk
1 ################################################################################
2 #
3 # procps-ng
4 #
5 ################################################################################
6
7 PROCPS_NG_VERSION = 3.3.15
8 PROCPS_NG_SOURCE = procps-ng-$(PROCPS_NG_VERSION).tar.xz
9 PROCPS_NG_SITE = http://downloads.sourceforge.net/project/procps-ng/Production
10 PROCPS_NG_LICENSE = GPL-2.0+, LGPL-2.0+ (libproc and libps)
11 PROCPS_NG_LICENSE_FILES = COPYING COPYING.LIB
12 PROCPS_NG_INSTALL_STAGING = YES
13 PROCPS_NG_DEPENDENCIES = ncurses host-pkgconf $(TARGET_NLS_DEPENDENCIES)
14 PROCPS_NG_CONF_OPTS = LIBS=$(TARGET_NLS_LIBS)
15
16 # If both procps-ng and busybox are selected, make certain procps-ng
17 # wins the fight over who gets to have their utils actually installed.
18 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
19 PROCPS_NG_DEPENDENCIES += busybox
20 endif
21
22 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
23 PROCPS_NG_DEPENDENCIES += systemd
24 PROCPS_NG_CONF_OPTS += --with-systemd
25 else
26 PROCPS_NG_CONF_OPTS += --without-systemd
27 endif
28
29 # Make sure binaries get installed in /bin, so that they overwrite
30 # their busybox counterparts.
31 # Make sure libprocps.pc is installed in STAGING_DIR/usr/lib/pkgconfig/
32 # otherwise it's installed in STAGING_DIR/lib/pkgconfig/ breaking
33 # pkg-config --libs libprocps.
34 PROCPS_NG_CONF_OPTS += --exec-prefix=/ \
35         --libdir=/usr/lib
36
37 # Allows unicode characters to show in 'watch'
38 ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
39 PROCPS_NG_CONF_OPTS += \
40         --enable-watch8bit
41 endif
42
43 ifeq ($(BR2_USE_WCHAR),)
44 PROCPS_NG_CONF_OPTS += CPPFLAGS=-DOFF_XTRAWIDE
45 endif
46
47 # numa support requires libdl, so explicitly disable it when
48 # BR2_STATIC_LIBS=y
49 ifeq ($(BR2_STATIC_LIBS),y)
50 PROCPS_NG_CONF_OPTS += --disable-numa
51 endif
52
53 $(eval $(autotools-package))