]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/daq/daq.mk
daq: add necessary dependencies on host-flex and host-bison
[coffee/buildroot.git] / package / daq / daq.mk
1 ################################################################################
2 #
3 # daq
4 #
5 ################################################################################
6
7 DAQ_VERSION = 2.0.6
8 DAQ_SITE = https://www.snort.org/downloads/snort
9 DAQ_LICENSE = GPL-2.0
10 DAQ_LICENSE_FILES = COPYING
11 DAQ_INSTALL_STAGING = YES
12 DAQ_DEPENDENCIES = host-bison host-flex
13
14 # package does not build in parallel due to improper make rules
15 # related to the generation of the tokdefs.h header file
16 DAQ_MAKE = $(MAKE1)
17
18 # disable ipq module as libipq is deprecated
19 DAQ_CONF_OPTS += --disable-ipq-module
20
21 ifeq ($(BR2_PACKAGE_LIBDNET)$(BR2_PACKAGE_LIBNETFILTER_QUEUE),yy)
22 DAQ_DEPENDENCIES += libdnet libnetfilter_queue
23 DAQ_CONF_OPTS += --enable-nfq-module
24 else
25 DAQ_CONF_OPTS += --disable-nfq-module
26 endif
27
28 ifeq ($(BR2_PACKAGE_LIBPCAP),y)
29 DAQ_DEPENDENCIES += libpcap
30 # assume these flags are available to prevent configure from running
31 # test programs while cross compiling
32 DAQ_CONF_ENV += \
33         ac_cv_lib_pcap_pcap_lib_version=yes \
34         daq_cv_libpcap_version_1x=yes
35 DAQ_CONF_OPTS += --enable-pcap-module
36 else
37 DAQ_CONF_OPTS += --disable-pcap-module
38 endif
39
40 $(eval $(autotools-package))