]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/sngrep/sngrep.mk
sngrep: fix libgcrypt handling
[coffee/buildroot.git] / package / sngrep / sngrep.mk
1 ################################################################################
2 #
3 # sngrep
4 #
5 ################################################################################
6
7 SNGREP_VERSION = v1.4.2
8 SNGREP_SITE = $(call github,irontec,sngrep,$(SNGREP_VERSION))
9 SNGREP_LICENSE = GPLv3+
10 SNGREP_LICENSE_FILES = LICENSE
11 SNGREP_AUTORECONF = YES
12 SNGREP_DEPENDENCIES = libpcap ncurses host-pkgconf
13
14 SNGREP_CONF_ENV += \
15         $(if $(BR2_STATIC_LIBS),LIBS="`$(STAGING_DIR)/usr/bin/pcap-config --static --libs`")
16
17 # our ncurses wchar support is not properly detected
18 SNGREP_CONF_OPTS += --disable-unicode
19
20 # openssl and gnutls can't be enabled at the same time.
21 ifeq ($(BR2_PACKAGE_OPENSSL),y)
22 SNGREP_DEPENDENCIES += openssl
23 SNGREP_CONF_OPTS += --with-openssl --without-gnutls
24 # gnutls support also requires libgcrypt
25 else ifeq ($(BR2_PACKAGE_GNUTLS)$(BR2_PACKAGE_LIBGCRYPT),yy)
26 SNGREP_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
27 SNGREP_DEPENDENCIES += gnutls libgcrypt
28 SNGREP_CONF_OPTS += --with-gnutls --without-openssl
29 else
30 SNGREP_CONF_OPTS += --without-gnutls --without-openssl
31 endif
32
33 ifeq ($(BR2_PACKAGE_PCRE),y)
34 SNGREP_DEPENDENCIES += pcre
35 SNGREP_CONF_OPTS += --with-pcre
36 else
37 SNGREP_CONF_OPTS += --without-pcre
38 endif
39
40 $(eval $(autotools-package))