]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/sngrep/sngrep.mk
sngrep: fix libgcrypt handling
[coffee/buildroot.git] / package / sngrep / sngrep.mk
1 ################################################################################
2 #
3 # sngrep
4 #
5 ################################################################################
6
7 SNGREP_VERSION = v1.4.5
8 SNGREP_SITE = $(call github,irontec,sngrep,$(SNGREP_VERSION))
9 SNGREP_LICENSE = GPL-3.0+
10 SNGREP_LICENSE_FILES = LICENSE
11 SNGREP_AUTORECONF = YES
12 SNGREP_DEPENDENCIES = libpcap ncurses host-pkgconf
13
14 SNGREP_CONF_ENV += \
15         $(if $(BR2_STATIC_LIBS),LIBS="`$(STAGING_DIR)/usr/bin/pcap-config --static --libs`")
16
17 SNGREP_CONF_OPTS += --disable-unicode
18
19 # openssl and gnutls can't be enabled at the same time.
20 ifeq ($(BR2_PACKAGE_OPENSSL),y)
21 SNGREP_DEPENDENCIES += openssl
22 SNGREP_CONF_OPTS += --with-openssl --without-gnutls
23 # gnutls support also requires libgcrypt
24 else ifeq ($(BR2_PACKAGE_GNUTLS)$(BR2_PACKAGE_LIBGCRYPT),yy)
25 SNGREP_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
26 SNGREP_DEPENDENCIES += gnutls libgcrypt
27 SNGREP_CONF_OPTS += --with-gnutls --without-openssl
28 else
29 SNGREP_CONF_OPTS += --without-gnutls --without-openssl
30 endif
31
32 ifeq ($(BR2_PACKAGE_PCRE),y)
33 SNGREP_DEPENDENCIES += pcre
34 SNGREP_CONF_OPTS += --with-pcre
35 else
36 SNGREP_CONF_OPTS += --without-pcre
37 endif
38
39 $(eval $(autotools-package))