]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/libpjsip/libpjsip.mk
libpjsip: fix ssl support
[coffee/buildroot.git] / package / libpjsip / libpjsip.mk
1 ################################################################################
2 #
3 # libpjsip
4 #
5 ################################################################################
6
7 LIBPJSIP_VERSION = 2.7.1
8 LIBPJSIP_SOURCE = pjproject-$(LIBPJSIP_VERSION).tar.bz2
9 LIBPJSIP_SITE = http://www.pjsip.org/release/$(LIBPJSIP_VERSION)
10 LIBPJSIP_DEPENDENCIES = libsrtp
11 LIBPJSIP_LICENSE = GPL-2.0+
12 LIBPJSIP_LICENSE_FILES = COPYING
13 LIBPJSIP_INSTALL_STAGING = YES
14 LIBPJSIP_MAKE = $(MAKE1)
15
16 LIBPJSIP_CFLAGS = $(TARGET_CFLAGS) -DPJ_HAS_IPV6=1
17
18 # relocation truncated to fit: R_68K_GOT16O
19 ifeq ($(BR2_m68k_cf),y)
20 LIBPJSIP_CFLAGS += -mxgot
21 endif
22
23 LIBPJSIP_CONF_ENV = \
24         LD="$(TARGET_CC)" \
25         CFLAGS="$(LIBPJSIP_CFLAGS)"
26
27 LIBPJSIP_CONF_OPTS = \
28         --disable-sound \
29         --disable-gsm-codec \
30         --disable-speex-codec \
31         --disable-speex-aec \
32         --disable-resample \
33         --disable-video \
34         --disable-opencore-amr \
35         --disable-g7221-codec \
36         --disable-ilbc-codec \
37         --disable-libwebrtc \
38         --disable-opus \
39         --disable-oss \
40         --disable-ext-sound \
41         --disable-small-filter \
42         --disable-large-filter \
43         --disable-g711-codec \
44         --disable-l16-codec \
45         --disable-g722-codec \
46         --disable-libsamplerate \
47         --disable-sdl \
48         --disable-ffmpeg \
49         --disable-v4l2 \
50         --disable-openh264 \
51         --disable-libyuv \
52         --disable-ipp \
53         --disable-silk \
54         --with-external-srtp
55
56 # Note: aconfigure.ac is broken: --enable-epoll or --disable-epoll will
57 # both enable it. But that's OK, epoll is better than the alternative,
58 # so we want to use it.
59 LIBPJSIP_CONF_OPTS += --enable-epoll
60
61 ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
62 LIBPJSIP_DEPENDENCIES += libopenssl
63 LIBPJSIP_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
64 else
65 LIBPJSIP_CONF_OPTS += --disable-ssl
66 endif
67
68 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
69 LIBPJSIP_DEPENDENCIES += util-linux
70 endif
71
72 $(eval $(autotools-package))