]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/tremor/tremor.mk
tremor: security bump to fix CVE-2018-5146
[coffee/buildroot.git] / package / tremor / tremor.mk
1 ################################################################################
2 #
3 # tremor
4 #
5 ################################################################################
6
7 TREMOR_VERSION = 7c30a66346199f3f09017a09567c6c8a3a0eedc8
8 TREMOR_SITE = https://git.xiph.org/tremor.git
9 TREMOR_SITE_METHOD = git
10 TREMOR_LICENSE = BSD-3-Clause
11 TREMOR_LICENSE_FILES = COPYING
12
13 TREMOR_AUTORECONF = YES
14 TREMOR_INSTALL_STAGING = YES
15 TREMOR_DEPENDENCIES = libogg
16
17 # tremor has ARM assembly code that cannot be compiled in Thumb2 mode,
18 # so we must force the traditional ARM mode.
19 # However, some ARM architectures like ARNv7-M only supports Thumb
20 # instructions, but the tremor build configuration enables ARM assembly
21 # code unconditionally for all arm triplets by defining _ARM_ASSEM_.
22 # We are overriding this by undefining this macro for the ARM
23 # architectures not supporting ARM instructions.
24 ifeq ($(BR2_arm),y)
25 ifeq ($(BR2_ARM_CPU_HAS_ARM),y)
26 TREMOR_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -marm"
27 else
28 TREMOR_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -U_ARM_ASSEM_"
29 endif
30 endif
31
32 $(eval $(autotools-package))