]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/stella/stella.mk
package/stella: fix project URLs
[coffee/buildroot.git] / package / stella / stella.mk
1 ################################################################################
2 #
3 # stella
4 #
5 ################################################################################
6
7 STELLA_VERSION = 4.7.2
8 STELLA_SOURCE = stella-$(STELLA_VERSION)-src.tar.xz
9 STELLA_SITE = https://github.com/stella-emu/stella/releases/download/release-$(STELLA_VERSION)
10 STELLA_LICENSE = GPL-2.0+
11 STELLA_LICENSE_FILES = Copyright.txt License.txt
12
13 STELLA_DEPENDENCIES = sdl2 libpng zlib
14
15 STELLA_CONF_OPTS = \
16         --host=$(GNU_TARGET_NAME) \
17         --prefix=/usr \
18         --with-sdl-prefix=$(STAGING_DIR)/usr
19
20 # The configure script is not autoconf based, so we use the
21 # generic-package infrastructure
22 define STELLA_CONFIGURE_CMDS
23         (cd $(@D); \
24                 $(TARGET_CONFIGURE_OPTS) \
25                 $(TARGET_CONFIGURE_ARGS) \
26                 ./configure $(STELLA_CONF_OPTS) \
27         )
28 endef
29
30 define STELLA_BUILD_CMDS
31         $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
32 endef
33
34 define STELLA_INSTALL_TARGET_CMDS
35         $(TARGET_MAKE_ENV) $(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
36 endef
37
38 $(eval $(generic-package))