]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/lame/lame.mk
lame: security bump to version 3.100
[coffee/buildroot.git] / package / lame / lame.mk
1 ################################################################################
2 #
3 # lame
4 #
5 ################################################################################
6
7 LAME_VERSION = 3.100
8 LAME_SITE = http://downloads.sourceforge.net/project/lame/lame/$(LAME_VERSION)
9 LAME_DEPENDENCIES = host-pkgconf
10 LAME_INSTALL_STAGING = YES
11 LAME_CONF_ENV = GTK_CONFIG=/bin/false
12 LAME_CONF_OPTS = --enable-dynamic-frontends
13 LAME_LICENSE = LGPLv2+
14 LAME_LICENSE_FILES = COPYING
15
16 ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
17 LAME_DEPENDENCIES += libsndfile
18 LAME_CONF_OPTS += --with-fileio=sndfile
19 endif
20
21 ifeq ($(BR2_PACKAGE_NCURSES),y)
22 LAME_DEPENDENCIES += ncurses
23 endif
24
25 ifeq ($(BR2_ENDIAN),"BIG")
26 define LAME_BIGENDIAN_ARCH
27         echo "#define WORDS_BIGENDIAN 1" >>$(@D)/config.h
28 endef
29 endif
30
31 LAME_POST_CONFIGURE_HOOKS += LAME_BIGENDIAN_ARCH
32
33 $(eval $(autotools-package))