]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/ti-cgt-pru/ti-cgt-pru.mk
package/ti-cgt-pru: bump to 2.2.1
[coffee/buildroot.git] / package / ti-cgt-pru / ti-cgt-pru.mk
1 ################################################################################
2 #
3 # ti-cgt-pru
4 #
5 ################################################################################
6
7 TI_CGT_PRU_VERSION = 2.2.1
8 TI_CGT_PRU_SOURCE = ti_cgt_pru_$(TI_CGT_PRU_VERSION)_linux_installer_x86.bin
9 TI_CGT_PRU_SITE = http://downloads.ti.com/codegen/esd/cgt_public_sw/PRU/$(TI_CGT_PRU_VERSION)
10 TI_CGT_PRU_LICENSE = TI Technology and Software Publicly Available License (compiler + PRU library), \
11         BSL-1.0 (compiler), BSD-2-Clause, BSD-3-Clause, MIT, AFL-3.0, Hewlett-Packard (PRU library)
12 TI_CGT_PRU_LICENSE_FILES = PRU_Code_Generation_Tools_2.2.x_manifest.html \
13         pru_rts_2_2_0_82167478-F8C9-49b2-82BD-12F8550770F9.spdx
14
15 define HOST_TI_CGT_PRU_EXTRACT_CMDS
16         chmod +x $(DL_DIR)/$(TI_CGT_PRU_SOURCE)
17         $(DL_DIR)/$(TI_CGT_PRU_SOURCE) --prefix $(@D) --mode unattended
18         mv $(@D)/ti-cgt-pru_$(TI_CGT_PRU_VERSION)/* $(@D)
19         rmdir $(@D)/ti-cgt-pru_$(TI_CGT_PRU_VERSION)/
20 endef
21
22 # Since this is largely prebuilt toolchain and likes to live in its
23 # own directory, put it in $(HOST_DIR)/share/ti-cgt-pru/.
24 # Packages wanting to use this toolchain need to use this path as TI's
25 # standard PRU_CGT path e.g. make PRU_CGT=$(TI_CGT_PRU_INSTALLDIR)...
26 TI_CGT_PRU_INSTALLDIR = $(HOST_DIR)/share/ti-cgt-pru
27
28 define HOST_TI_CGT_PRU_INSTALL_CMDS
29         mkdir -p $(TI_CGT_PRU_INSTALLDIR)
30         cp -dpfr $(@D)/* $(TI_CGT_PRU_INSTALLDIR)
31 endef
32
33 $(eval $(host-generic-package))