]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/jq/jq.mk
jq: compile as _GNU_SOURCE to fix segfault when compiled with gcc 6
[coffee/buildroot.git] / package / jq / jq.mk
1 ################################################################################
2 #
3 # jq
4 #
5 ################################################################################
6
7 JQ_VERSION = 1.5
8 JQ_SITE = https://github.com/stedolan/jq/releases/download/jq-$(JQ_VERSION)
9 JQ_LICENSE = MIT (code), CC-BY-3.0 (documentation)
10 JQ_LICENSE_FILES = COPYING
11
12 # uses c99 specific features
13 # _GNU_SOURCE added to fix gcc6+ host compilation
14 # (https://github.com/stedolan/jq/issues/1598)
15 JQ_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99 -D_GNU_SOURCE"
16 HOST_JQ_CONF_ENV += CFLAGS="$(HOST_CFLAGS) -std=c99 -D_GNU_SOURCE"
17
18 # jq explicitly enables maintainer mode, which we don't need/want
19 JQ_CONF_OPTS += --disable-maintainer-mode
20 HOST_JQ_CONF_OPTS += --disable-maintainer-mode
21
22 $(eval $(autotools-package))
23 $(eval $(host-autotools-package))