]> rtime.felk.cvut.cz Git - sojka/sterm.git/blob - default.nix
default.nix: include completion
[sojka/sterm.git] / default.nix
1 {
2   nixpkgs ? <nixpkgs>,
3   pkgs ? import nixpkgs {}
4 }:
5 with pkgs;
6 stdenv.mkDerivation {
7   name = "sterm";
8   src = ./.;
9   nativeBuildInputs = [ pkgs.installShellFiles ];
10   installPhase = ''
11     make install PREFIX=$out NO_COMP=1
12     installShellCompletion --bash --name sterm completion.bash
13     installShellCompletion --zsh --name _sterm completion.zsh
14   '';
15
16 }