]> rtime.felk.cvut.cz Git - sojka/lightdm.git/blob - debian/patches/01_transition_ubuntu2d_ubuntu_desktop.patch
Update debian/patches
[sojka/lightdm.git] / debian / patches / 01_transition_ubuntu2d_ubuntu_desktop.patch
1 # Description: Remove unity-2d (not anymore supported) and transition to unity
2 #              starting from quantal. llvmpipe is used in case no hardware
3 #              acceleration is available.
4 === modified file 'liblightdm-gobject/user.c'
5 Index: user-refactor/liblightdm-gobject/user.c
6 ===================================================================
7 --- user-refactor.orig/liblightdm-gobject/user.c        2013-10-29 16:16:48.505903621 -0700
8 +++ user-refactor/liblightdm-gobject/user.c     2013-10-29 16:16:48.501905620 -0700
9 @@ -1115,6 +1115,12 @@
10          load_accounts_user (user);
11      else
12          load_dmrc (user);
13
14 +    if (g_strcmp0 (priv->session, "ubuntu-2d") == 0)
15 +    {
16 +        g_free(priv->session);
17 +        priv->session = g_strdup ("ubuntu");
18 +    }
19  }
20  
21  /**