]> rtime.felk.cvut.cz Git - sojka/lightdm.git/blob - debian/rules
Merge with trunk
[sojka/lightdm.git] / debian / rules
1 #!/usr/bin/make -f 
2
3 LDFLAGS+=-Wl,--as-needed
4
5 %:
6         dh $@ --with quilt,autoreconf,translations
7
8 override_dh_autoreconf:
9         NOCONFIGURE=1 dh_autoreconf ./autogen.sh
10
11 # NOTE: Using GNOME for now, but we still need a proper configuration system
12 # See https://launchpad.net/bugs/799754
13 override_dh_auto_configure:
14         dh_auto_configure -- --with-greeter-user=lightdm --with-user-session=ubuntu --enable-gtk-doc
15
16 override_dh_auto_test:
17         # lightdm must be installed in prefix before tests will succeed, so we run
18         # them as a dep8 test instead of during build
19
20 override_dh_install:
21         #Remove .la and .a files.
22         find debian/tmp/usr/lib/ -name *.a |xargs rm
23         find debian/tmp/usr/lib -name *.la |xargs rm
24         #Remove conf files from upstream
25         #find debian/tmp/etc/ -name *.conf |xargs rm
26         #find debian/tmp/etc/init -name *.conf |xargs rm
27         dh_install --list-missing
28         mv debian/lightdm/usr/lib/lightdm/lightdm/lightdm-set-defaults debian/lightdm/usr/lib/lightdm
29         chmod +x debian/lightdm/usr/lib/lightdm/lightdm-greeter-session
30
31 override_dh_installinit:
32         dh_installinit --no-start
33
34 override_dh_installpam:
35         dh_installpam
36         dh_installpam --name=lightdm-autologin
37         dh_installpam --name=lightdm-greeter
38         
39 override_dh_makeshlibs:
40         dh_makeshlibs -pliblightdm-gobject-1-0 -V'liblightdm-gobject-1-0 (>= 0.9.2)' -- -c4
41         dh_makeshlibs -Nliblightdm-gobject-1-0