]> rtime.felk.cvut.cz Git - sojka/debian/lightdm.git/blob - debian/patches/03_fix-pam_chauthtok-call.patch
upload
[sojka/debian/lightdm.git] / debian / patches / 03_fix-pam_chauthtok-call.patch
1 --- a/src/session-child.c
2 +++ b/src/session-child.c
3 @@ -336,7 +336,7 @@ session_child_run (int argc, char **argv
4          if (authentication_result == PAM_SUCCESS)
5              authentication_result = pam_acct_mgmt (pam_handle, 0);
6          if (authentication_result == PAM_NEW_AUTHTOK_REQD)
7 -            authentication_result = pam_chauthtok (pam_handle, 0);
8 +            authentication_result = pam_chauthtok (pam_handle, PAM_CHANGE_EXPIRED_AUTHTOK);
9      }
10      else
11          authentication_result = PAM_SUCCESS;