]> rtime.felk.cvut.cz Git - sojka/debian/lightdm.git/blob - debian/patches/03_quit-plymouth.patch
add DEP3 headers
[sojka/debian/lightdm.git] / debian / patches / 03_quit-plymouth.patch
1 Author: Yves-Alexis Perez <corsac@debian.org>
2 Description: quit plymouth instead of deactivating it
3 plymouth is quitted from the /etc/init.d/plymouth script, but it'll hang if
4 plymouth has been deactivated before, so just quit it for now.
5 Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=632737
6 Bug: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/799069
7 diff --git a/src/display-manager.c b/src/display-manager.c
8 index c8f5f32..5191fcc 100644
9 --- a/src/display-manager.c
10 +++ b/src/display-manager.c
11 @@ -616,7 +616,7 @@ display_manager_start (DisplayManager *manager)
12          plymouth_on_active_vt = plymouth_command_returns_true ("--has-active-vt");
13  
14          /* Deactivate stops Plymouth from drawing, as we are about to start an X server to replace it */
15 -        plymouth_run_command ("deactivate", NULL);
16 +        plymouth_run_command ("quit", NULL);
17      }
18  
19      /* Start each static display */