]> rtime.felk.cvut.cz Git - sojka/debian/lightdm.git/blob - debian/patches/05_dont-add-pkglibexecdir-path.patch
* New upstream release.
[sojka/debian/lightdm.git] / debian / patches / 05_dont-add-pkglibexecdir-path.patch
1 Index: lightdm-1.0.3/src/session.c
2 ===================================================================
3 --- lightdm-1.0.3.orig/src/session.c    2011-10-08 13:29:42.102575779 +0200
4 +++ lightdm-1.0.3/src/session.c 2011-10-08 13:29:55.526679659 +0200
5 @@ -217,26 +217,6 @@
6      }
7  }
8  
9 -/* Insert our own utility directory to PATH
10 - * This is to provide gdmflexiserver which provides backwards compatibility
11 - * with GDM.
12 - * Must be done after set_env_from_authentication because PAM sets PATH.
13 - * This can be removed when this is no longer required.
14 - */
15 -static void
16 -insert_utility_path (Session *session)
17 -{
18 -    const gchar *orig_path;
19 -
20 -    orig_path = session_get_env (session, "PATH");
21 -    if (orig_path)
22 -    {
23 -        gchar *path = g_strdup_printf ("%s:%s", PKGLIBEXEC_DIR, orig_path);
24 -        session_set_env (session, "PATH", path);
25 -        g_free (path);
26 -    }
27 -}
28 -
29  gboolean
30  session_start (Session *session)
31  {
32 @@ -436,7 +416,6 @@
33      pam_session_setup (session->priv->authentication);
34      set_env_from_authentication (session, session->priv->authentication);
35      set_locale (session);
36 -    insert_utility_path (session);
37  
38      PROCESS_CLASS (session_parent_class)->run (process);
39  }