]> rtime.felk.cvut.cz Git - sojka/debian/lightdm.git/blob - debian/patches/05_dont-add-pkglibexecdir-path.patch
add description/bug/author to patches
[sojka/debian/lightdm.git] / debian / patches / 05_dont-add-pkglibexecdir-path.patch
1 Author: Yves-Alexis Perez <corsac@debian.org>
2 Description: don't add PKGLIBEXEC_DIR to the user PATH
3 Index: lightdm-1.0.3/src/session.c
4 ===================================================================
5 --- lightdm-1.0.3.orig/src/session.c    2011-10-08 13:29:42.102575779 +0200
6 +++ lightdm-1.0.3/src/session.c 2011-10-08 13:29:55.526679659 +0200
7 @@ -217,26 +217,6 @@
8      }
9  }
10  
11 -/* Insert our own utility directory to PATH
12 - * This is to provide gdmflexiserver which provides backwards compatibility
13 - * with GDM.
14 - * Must be done after set_env_from_authentication because PAM sets PATH.
15 - * This can be removed when this is no longer required.
16 - */
17 -static void
18 -insert_utility_path (Session *session)
19 -{
20 -    const gchar *orig_path;
21 -
22 -    orig_path = session_get_env (session, "PATH");
23 -    if (orig_path)
24 -    {
25 -        gchar *path = g_strdup_printf ("%s:%s", PKGLIBEXEC_DIR, orig_path);
26 -        session_set_env (session, "PATH", path);
27 -        g_free (path);
28 -    }
29 -}
30 -
31  gboolean
32  session_start (Session *session)
33  {
34 @@ -436,7 +416,6 @@
35      pam_session_setup (session->priv->authentication);
36      set_env_from_authentication (session, session->priv->authentication);
37      set_locale (session);
38 -    insert_utility_path (session);
39  
40      PROCESS_CLASS (session_parent_class)->run (process);
41  }