]> rtime.felk.cvut.cz Git - sojka/debian/lightdm.git/blob - debian/rules
merge changes from experimental branch
[sojka/debian/lightdm.git] / debian / rules
1 #!/usr/bin/make -f
2
3 export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed -Wl,-O1
4 #export DEB_BUILD_MAINT_OPTIONS=hardening=+all
5
6 DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
7
8 override_dh_auto_configure:
9         dh_auto_configure -- --with-greeter-user=lightdm --with-user-session=lightdm-xsession --enable-introspection=yes --disable-silent-rules
10
11 override_dh_installchangelogs:
12         dh_installchangelogs -- NEWS
13
14 override_dh_installinit:
15         dh_installinit --noscripts
16
17 override_dh_install:
18         find debian/tmp -name '*.la' -delete
19         find debian/tmp/usr/lib/ -name gdmflexiserver -delete
20         find debian/tmp/etc/apparmor.d -type f -exec chmod 0644 '{}' \;
21         dh_install --fail-missing -X etc/init/lightdm.conf
22
23 %:
24         dh $@ --parallel
25
26 override_dh_auto_test: