]> rtime.felk.cvut.cz Git - novaboot.git/blob - flake.nix
nix: Update flake inputs
[novaboot.git] / flake.nix
1 {
2   description = "novaboot";
3
4   inputs = {
5     # The nixpkgs entry in the flake registry.
6     nixpkgs.url = github:NixOS/nixpkgs/nixos-unstable;
7     flake-utils.url = "github:numtide/flake-utils";
8   };
9
10   outputs = { self, nixpkgs, flake-utils }:
11     flake-utils.lib.eachDefaultSystem (system:
12       let
13         pkgs = nixpkgs.legacyPackages.${system};
14         novaboot = (import ./novaboot.nix { inherit self pkgs; });
15       in {
16         # Utilized by `nix build .`
17         defaultPackage = novaboot.novaboot;
18
19         packages.novaboot = novaboot.novaboot;
20         packages.novaboot-server = novaboot.novaboot_server;
21
22         devShell = pkgs.mkShell {
23           inputsFrom = [
24             (import ./novaboot.nix {
25               inherit self pkgs;
26               otherPerlPackages = [ pkgs.perl.pkgs.PodParser ];
27             }).novaboot
28           ];
29           buildInputs = with pkgs; [
30             syslinux
31             cdrkit
32             grub2
33             dhcp
34           ];
35         };
36
37         # Default overlay, for use in dependent flakes
38         overlay = final: prev: { };
39
40         # Default module, for use in dependent flakes
41         #nixosModule = { config, ... }: { options = {}; config = {}; };
42
43         # Same idea as nixosModule but a list or attrset of them.
44         #nixosModules = { exampleModule = self.nixosModule; };
45       });
46 }