]> rtime.felk.cvut.cz Git - hercules2020/hercules-compiler.git/blob - debian/patches/use_gpuguard.patch
Update HerculesCompiler and openmp submodules
[hercules2020/hercules-compiler.git] / debian / patches / use_gpuguard.patch
1 --- a/HerculesCompiler/libpremnotify/libpremnotify-gpu.cu
2 +++ b/HerculesCompiler/libpremnotify/libpremnotify-gpu.cu
3 @@ -47,7 +47,7 @@
4  // SYNC: We can use GPUguard, synchronization, or (if none of the below macros
5  //       are defined), no sync at all.
6  // Use GPUguard for synchronization
7 -#define USE_GPUGUARD
8 +// #define USE_GPUGUARD
9  
10  // Use barriers for synchronization
11  #define USE_BARRIERS
12 --- a/openmp/libomptarget/plugins/cuda/src/rtl.cpp
13 +++ b/openmp/libomptarget/plugins/cuda/src/rtl.cpp
14 @@ -19,7 +19,7 @@
15  // kernel, and the LKM will be invoked for synchronization. If it is not 
16  // defined, the offloading will be done as in the original libomptarget CUDA
17  // rtl.
18 -#define USE_GPUGUARD
19 +// #define USE_GPUGUARD
20  
21  // After each kernel, finalize the results to get output in deadline misses and
22  // enable the GPUguard LKM to output more statistics to the kernel log (if