]> rtime.felk.cvut.cz Git - hercules2020/hercules-compiler.git/blob - debian/rules
Update rules
[hercules2020/hercules-compiler.git] / debian / rules
1 #!/usr/bin/make -f
2 # See debhelper(7) (uncomment to enable)
3 # output every command that modifies files on the build system.
4 #export DH_VERBOSE = 1
5
6
7 # see FEATURE AREAS in dpkg-buildflags(1)
8 #export DEB_BUILD_MAINT_OPTIONS = hardening=+all
9
10 # see ENVIRONMENT in dpkg-buildflags(1)
11 # package maintainers to append CFLAGS
12 #export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
13 # package maintainers to append LDFLAGS
14 #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
15
16
17 %:
18         dh $@
19
20 override_dh_auto_build:
21         $(MAKE) PREFIX=/opt/hercules-compiler
22
23 override_dh_auto_install:
24         $(MAKE) PREFIX=/opt/hercules-compiler DESTDIR=$(DESTDIR) install
25
26 # override_dh_strip:
27 #       @echo "Skipping dh_strip"
28
29 # dh_make generated override targets
30 # This is example for Cmake (See https://bugs.debian.org/641051 )
31 #override_dh_auto_configure:
32 #       dh_auto_configure -- #  -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)