]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/strace/strace.mk
strace: disable (again) mpers for musl
[coffee/buildroot.git] / package / strace / strace.mk
1 ################################################################################
2 #
3 # strace
4 #
5 ################################################################################
6
7 STRACE_VERSION = 4.21
8 STRACE_SOURCE = strace-$(STRACE_VERSION).tar.xz
9 STRACE_SITE = https://strace.io/files/$(STRACE_VERSION)
10 STRACE_LICENSE = BSD-3-Clause
11 STRACE_LICENSE_FILES = COPYING
12 STRACE_CONF_OPTS = --enable-mpers=check
13
14 # strace bundle some kernel headers to build libmpers, this mixes userspace
15 # headers and kernel headers which break the build with musl.
16 # The stddef.h from gcc is used instead of the one from musl.
17 ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
18 STRACE_CONF_OPTS += st_cv_m32_mpers=no \
19         st_cv_mx32_mpers=no
20 endif
21
22 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
23 STRACE_DEPENDENCIES += libunwind
24 STRACE_CONF_OPTS += --with-libunwind
25 else
26 STRACE_CONF_OPTS += --without-libunwind
27 endif
28
29 define STRACE_REMOVE_STRACE_GRAPH
30         rm -f $(TARGET_DIR)/usr/bin/strace-graph
31 endef
32
33 STRACE_POST_INSTALL_TARGET_HOOKS += STRACE_REMOVE_STRACE_GRAPH
34
35 $(eval $(autotools-package))