]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/janus-gateway/janus-gateway.mk
janus-gateway: bump to v0.2.2
[coffee/buildroot.git] / package / janus-gateway / janus-gateway.mk
1 ################################################################################
2 #
3 # janus-gateway
4 #
5 ################################################################################
6
7 JANUS_GATEWAY_VERSION = v0.2.2
8 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,$(JANUS_GATEWAY_VERSION))
9 JANUS_GATEWAY_LICENSE = GPLv3
10 JANUS_GATEWAY_LICENSE_FILES = COPYING
11
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
14         libsrtp host-gengetopt libglib2 openssl
15
16 # Straight out of the repository, no ./configure, and we also patch
17 # configure.ac.
18 JANUS_GATEWAY_AUTORECONF = YES
19
20 define JANUS_GATEWAY_M4
21         mkdir -p $(@D)/m4
22 endef
23 JANUS_GATEWAY_POST_PATCH_HOOKS += JANUS_GATEWAY_M4
24
25 JANUS_GATEWAY_CONF_OPTS = \
26         --disable-data-channels \
27         --disable-rabbitmq \
28         --disable-sample-event-handler
29
30 ifeq ($(BR2_PACKAGE_JANUS_AUDIO_BRIDGE),y)
31 JANUS_GATEWAY_DEPENDENCIES += opus
32 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-audiobridge
33 else
34 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-audiobridge
35 endif
36
37 ifeq ($(BR2_PACKAGE_JANUS_ECHO_TEST),y)
38 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-echotest
39 else
40 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-echotest
41 endif
42
43 ifeq ($(BR2_PACKAGE_JANUS_RECORDPLAY),y)
44 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-recordplay
45 else
46 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-recordplay
47 endif
48
49 ifeq ($(BR2_PACKAGE_JANUS_SIP_GATEWAY),y)
50 JANUS_GATEWAY_DEPENDENCIES += sofia-sip
51 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-sip
52 else
53 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-sip
54 endif
55
56 ifeq ($(BR2_PACKAGE_JANUS_STREAMING),y)
57 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-streaming
58 else
59 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-streaming
60 endif
61
62 ifeq ($(BR2_PACKAGE_JANUS_TEXT_ROOM),y)
63 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-textroom
64 else
65 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-textroom
66 endif
67
68 ifeq ($(BR2_PACKAGE_JANUS_VIDEO_CALL),y)
69 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-videocall
70 else
71 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-videocall
72 endif
73
74 ifeq ($(BR2_PACKAGE_JANUS_VIDEO_ROOM),y)
75 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-videoroom
76 else
77 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-videoroom
78 endif
79
80 ifeq ($(BR2_PACKAGE_JANUS_VOICE_MAIL),y)
81 JANUS_GATEWAY_DEPENDENCIES += libogg
82 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-voicemail
83 else
84 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-voicemail
85 endif
86
87 ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS),y)
88 JANUS_GATEWAY_DEPENDENCIES += libwebsockets
89 JANUS_GATEWAY_CONF_OPTS += --enable-websockets
90 else
91 JANUS_GATEWAY_CONF_OPTS += --disable-websockets
92 endif
93
94 # Parallel build broken
95 JANUS_GATEWAY_MAKE = $(MAKE1)
96
97 $(eval $(autotools-package))