]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/znc/znc.mk
package/znc: bump version to 1.7.0
[coffee/buildroot.git] / package / znc / znc.mk
1 ################################################################################
2 #
3 # znc
4 #
5 ################################################################################
6
7 ZNC_VERSION = 1.7.0
8 ZNC_SITE = http://znc.in/releases/archive
9 ZNC_LICENSE = Apache-2.0
10 ZNC_LICENSE_FILES = LICENSE
11 ZNC_DEPENDENCIES = host-pkgconf
12 ZNC_CONF_OPTS = --disable-perl
13
14 ifeq ($(BR2_PACKAGE_ICU),y)
15 ZNC_DEPENDENCIES += icu
16 ZNC_CONF_OPTS += --enable-charset
17 else
18 ZNC_CONF_OPTS += --disable-charset
19 endif
20
21 ifeq ($(BR2_PACKAGE_OPENSSL),y)
22 ZNC_DEPENDENCIES += openssl
23 ZNC_CONF_OPTS += --enable-openssl
24 else
25 ZNC_CONF_OPTS += --disable-openssl
26 endif
27
28 ifeq ($(BR2_PACKAGE_ZLIB),y)
29 ZNC_DEPENDENCIES += zlib
30 ZNC_CONF_OPTS += --enable-zlib
31 else
32 ZNC_CONF_OPTS += --disable-zlib
33 endif
34
35 ifeq ($(BR2_PACKAGE_PYTHON3),y)
36 ZNC_DEPENDENCIES += python3 host-swig
37 ZNC_CONF_OPTS += --enable-python=python3
38 else
39 ZNC_CONF_OPTS += --disable-python
40 endif
41
42 $(eval $(autotools-package))