]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/opentyrian/opentyrian.mk
package/tyrian: fixes compilation with static libs
[coffee/buildroot.git] / package / opentyrian / opentyrian.mk
1 ################################################################################
2 #
3 # opentyrian
4 #
5 ################################################################################
6
7 OPENTYRIAN_VERSION = 9c9f0ec3532b
8 OPENTYRIAN_SITE = https://bitbucket.org/opentyrian/opentyrian
9 OPENTYRIAN_SITE_METHOD = hg
10 OPENTYRIAN_LICENSE = GPL-2.0+
11 OPENTYRIAN_LICENSE_FILES = COPYING
12
13 OPENTYRIAN_DEPENDENCIES = sdl
14
15 ifeq ($(BR2_PACKAGE_OPENTYRIAN_NET),y)
16 OPENTYRIAN_DEPENDENCIES += sdl_net
17 OPENTYRIAN_NETWORK = true
18 else
19 OPENTYRIAN_NETWORK = false
20 endif
21
22 define OPENTYRIAN_BUILD_CMDS
23         $(TARGET_MAKE_ENV) $(MAKE) PLATFORM=UNIX \
24                 CC="$(TARGET_CC)" \
25                 STRIP="/bin/true" \
26                 SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config" \
27                 LDFLAGS="$(TARGET_LDFLAGS) -lm" \
28                 WITH_NETWORK="$(OPENTYRIAN_NETWORK)" \
29                 -C $(@D) release
30 endef
31
32 define OPENTYRIAN_INSTALL_TARGET_CMDS
33         $(INSTALL) -D -m 0755 $(@D)/opentyrian $(TARGET_DIR)/usr/bin/opentyrian
34 endef
35
36 $(eval $(generic-package))