]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/omniorb/omniorb.mk
omniorb: cleanup autobuild failure, CFLAGS issue
[coffee/buildroot.git] / package / omniorb / omniorb.mk
1 ################################################################################
2 #
3 # omniorb
4 #
5 ################################################################################
6
7 OMNIORB_VERSION = 4.1.6
8 OMNIORB_SITE = http://downloads.sourceforge.net/project/omniorb/omniORB/omniORB-$(OMNIORB_VERSION)
9 OMNIORB_SOURCE = omniORB-$(OMNIORB_VERSION).tar.bz2
10 OMNIORB_INSTALL_STAGING = YES
11 OMNIORB_LICENSE = GPL2+ LGPLv2.1+
12 OMNIORB_LICENSE_FILES = COPYING COPYING.LIB
13 OMNIORB_DEPENDENCIES = host-omniorb
14 HOST_OMNIORB_DEPENDENCIES = host-python
15 OMNIORB_INSTALL_TARGET = YES
16
17 # Defaulting long double support to a safe option for the
18 # mix of embedded targets, this could later be automated
19 # based on checking the capability of the cross toolchain
20 # for "__LONG_DOUBLE_128__".  Currently the host and target
21 # need to match because of the code generation done by the
22 # host tools during the target compile (ie headers generated
23 # on host are used in target build).
24 OMNIORB_CONF_OPT += --disable-longdouble
25 HOST_OMNIORB_CONF_OPT += --disable-longdouble
26
27 # omniORB is not completely cross-compile friendly and has some
28 # assumptions where a couple host tools must be built and then
29 # used by the target build.  The host tools generate code from
30 # the IDL description language, which is then built into the
31 # cross compiled target OMNIORB application.
32 define OMNIORB_ADJUST_TOOLDIR
33         # Point to the host folder to get HOST_OMNIORB tools
34         $(SED) 's:TOOLBINDIR = $$(TOP)/$$(BINDIR):TOOLBINDIR = $(HOST_DIR)/usr/bin:g' $(@D)/mk/beforeauto.mk
35         # Disables OMNIORB tool building
36         echo "EmbeddedSystem=1" >> $(@D)/mk/beforeauto.mk
37 endef
38 OMNIORB_POST_CONFIGURE_HOOKS += OMNIORB_ADJUST_TOOLDIR
39
40 $(eval $(autotools-package))
41 $(eval $(host-autotools-package))