]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/omniorb/omniorb.mk
omniorb: add option to build applications and services
[coffee/buildroot.git] / package / omniorb / omniorb.mk
1 ################################################################################
2 #
3 # omniorb
4 #
5 ################################################################################
6
7 OMNIORB_VERSION = 4.1.6
8 OMNIORB_SITE = http://downloads.sourceforge.net/project/omniorb/omniORB/omniORB-$(OMNIORB_VERSION)
9 OMNIORB_SOURCE = omniORB-$(OMNIORB_VERSION).tar.bz2
10 OMNIORB_INSTALL_STAGING = YES
11 OMNIORB_LICENSE = GPL2+ LGPLv2.1+
12 OMNIORB_LICENSE_FILES = COPYING COPYING.LIB
13 OMNIORB_DEPENDENCIES = host-omniorb
14 HOST_OMNIORB_DEPENDENCIES = host-python
15 OMNIORB_INSTALL_TARGET = YES
16
17 # Defaulting long double support to a safe option for the
18 # mix of embedded targets, this could later be automated
19 # based on checking the capability of the cross toolchain
20 # for "__LONG_DOUBLE_128__".  Currently the host and target
21 # need to match because of the code generation done by the
22 # host tools during the target compile (ie headers generated
23 # on host are used in target build).
24 OMNIORB_CONF_OPT += --disable-longdouble
25 HOST_OMNIORB_CONF_OPT += --disable-longdouble
26
27 # The EmbeddedSystem define (set below in OMNIORB_ADJUST_TOOLDIR)
28 # enables building of just the lib and disables building of
29 # tools/apps/services.  In some cases the apps/services are still
30 # required.  The tools however are host related and should never
31 # be required on target.
32 define OMNIORB_ENABLE_EXTRA_APPS
33 $(SED) 's:SUBDIRS += lib:SUBDIRS += lib appl services:g' $(@D)/src/dir.mk
34 endef
35
36 ifeq ($(BR2_PACKAGE_OMNIORB_WITH_APPS),y)
37 OMNIORB_POST_PATCH_HOOKS += OMNIORB_ENABLE_EXTRA_APPS
38 endif
39
40 # omniORB is not completely cross-compile friendly and has some
41 # assumptions where a couple host tools must be built and then
42 # used by the target build.  The host tools generate code from
43 # the IDL description language, which is then built into the
44 # cross compiled target OMNIORB application.
45 define OMNIORB_ADJUST_TOOLDIR
46         # Point to the host folder to get HOST_OMNIORB tools
47         $(SED) 's:TOOLBINDIR = $$(TOP)/$$(BINDIR):TOOLBINDIR = $(HOST_DIR)/usr/bin:g' $(@D)/mk/beforeauto.mk
48         # Disables OMNIORB app/service/tool building
49         echo "EmbeddedSystem=1" >> $(@D)/mk/beforeauto.mk
50 endef
51 OMNIORB_POST_CONFIGURE_HOOKS += OMNIORB_ADJUST_TOOLDIR
52
53 $(eval $(autotools-package))
54 $(eval $(host-autotools-package))