]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/janus-gateway/janus-gateway.mk
janus-gateway: rename options to have proper prefix
[coffee/buildroot.git] / package / janus-gateway / janus-gateway.mk
1 ################################################################################
2 #
3 # janus-gateway
4 #
5 ################################################################################
6
7 JANUS_GATEWAY_VERSION = v0.2.6
8 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,$(JANUS_GATEWAY_VERSION))
9 JANUS_GATEWAY_LICENSE = GPL-3.0
10 JANUS_GATEWAY_LICENSE_FILES = COPYING
11
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
14         libsrtp host-gengetopt libglib2 openssl
15
16 # Straight out of the repository, no ./configure, and we also patch
17 # configure.ac.
18 JANUS_GATEWAY_AUTORECONF = YES
19
20 define JANUS_GATEWAY_M4
21         mkdir -p $(@D)/m4
22 endef
23 JANUS_GATEWAY_POST_PATCH_HOOKS += JANUS_GATEWAY_M4
24
25 JANUS_GATEWAY_CONF_OPTS = \
26         --disable-data-channels \
27         --disable-sample-event-handler
28
29 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_AUDIO_BRIDGE),y)
30 JANUS_GATEWAY_DEPENDENCIES += opus
31 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-audiobridge
32 else
33 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-audiobridge
34 endif
35
36 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_ECHO_TEST),y)
37 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-echotest
38 else
39 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-echotest
40 endif
41
42 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_RECORDPLAY),y)
43 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-recordplay
44 else
45 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-recordplay
46 endif
47
48 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_SIP_GATEWAY),y)
49 JANUS_GATEWAY_DEPENDENCIES += sofia-sip
50 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-sip
51 else
52 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-sip
53 endif
54
55 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_STREAMING),y)
56 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-streaming
57 else
58 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-streaming
59 endif
60
61 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_TEXT_ROOM),y)
62 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-textroom
63 else
64 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-textroom
65 endif
66
67 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_VIDEO_CALL),y)
68 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-videocall
69 else
70 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-videocall
71 endif
72
73 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_VIDEO_ROOM),y)
74 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-videoroom
75 else
76 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-videoroom
77 endif
78
79 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_VOICE_MAIL),y)
80 JANUS_GATEWAY_DEPENDENCIES += libogg
81 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-voicemail
82 else
83 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-voicemail
84 endif
85
86 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_MQTT),y)
87 JANUS_GATEWAY_DEPENDENCIES += paho-mqtt-c
88 JANUS_GATEWAY_CONF_OPTS += --enable-mqtt
89 else
90 JANUS_GATEWAY_CONF_OPTS += --disable-mqtt
91 endif
92
93 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_RABBITMQ),y)
94 JANUS_GATEWAY_DEPENDENCIES += rabbitmq-c
95 JANUS_GATEWAY_CONF_OPTS += --enable-rabbitmq
96 else
97 JANUS_GATEWAY_CONF_OPTS += --disable-rabbitmq
98 endif
99
100 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_REST),y)
101 JANUS_GATEWAY_DEPENDENCIES += libmicrohttpd
102 JANUS_GATEWAY_CONF_OPTS += --enable-rest
103 else
104 JANUS_GATEWAY_CONF_OPTS += --disable-rest
105 endif
106
107 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_UNIX_SOCKETS),y)
108 JANUS_GATEWAY_CONF_OPTS += --enable-unix-sockets
109 else
110 JANUS_GATEWAY_CONF_OPTS += --disable-unix-sockets
111 endif
112
113 ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_WEBSOCKETS),y)
114 JANUS_GATEWAY_DEPENDENCIES += libwebsockets
115 JANUS_GATEWAY_CONF_OPTS += --enable-websockets
116 else
117 JANUS_GATEWAY_CONF_OPTS += --disable-websockets
118 endif
119
120 # Parallel build broken
121 JANUS_GATEWAY_MAKE = $(MAKE1)
122
123 $(eval $(autotools-package))