]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/yasm/yasm.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / yasm / yasm.mk
1 ################################################################################
2 #
3 # yasm
4 #
5 ################################################################################
6
7 YASM_VERSION = 1.3.0
8 YASM_SITE = http://www.tortall.net/projects/yasm/releases
9 YASM_LICENSE = BSD-2-Clause, BSD-3-Clause, Artistic, GPL-2.0, LGPL-2.0
10 YASM_LICENSE_FILES = COPYING BSD.txt Artistic.txt GNU_GPL-2.0 GNU_LGPL-2.0
11
12 # This sed prevents it compiling 2 programs (vsyasm and ytasm)
13 # that are only of use on Microsoft Windows.
14 define YASM_PRE_CONFIGURE_FIXUP
15         $(SED) 's#) ytasm.*#)#' $(@D)/Makefile.in
16 endef
17
18 YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
19 HOST_YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
20
21 $(eval $(autotools-package))
22 $(eval $(host-autotools-package))