]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/waylandpp/waylandpp.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / waylandpp / waylandpp.mk
1 ################################################################################
2 #
3 # waylandpp
4 #
5 ################################################################################
6
7 WAYLANDPP_VERSION = 0.2.2
8 WAYLANDPP_SITE = $(call github,NilsBrause,waylandpp,$(WAYLANDPP_VERSION))
9 WAYLANDPP_LICENSE = MIT, GPL-3.0+ (wayland_scanner)
10 WAYLANDPP_LICENSE_FILES = LICENSE scanner/gpl-3.0.txt
11 WAYLANDPP_INSTALL_STAGING = YES
12 HOST_WAYLANDPP_DEPENDENCIES = host-pkgconf host-wayland
13 WAYLANDPP_DEPENDENCIES = libegl host-pkgconf wayland host-waylandpp
14
15 # host variant of wayland-scanner++ is needed for building the target
16 # package
17 HOST_WAYLANDPP_CONF_OPTS = \
18         -DBUILD_LIBRARIES=OFF \
19         -DBUILD_SCANNER=ON
20
21 WAYLANDPP_CONF_OPTS = \
22         -DBUILD_LIBRARIES=ON \
23         -DBUILD_SCANNER=OFF \
24         -DWAYLAND_SCANNERPP=$(HOST_DIR)/bin/wayland-scanner++
25
26 $(eval $(cmake-package))
27 $(eval $(host-cmake-package))