]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/ranger/ranger.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / ranger / ranger.mk
1 ################################################################################
2 #
3 # ranger
4 #
5 ################################################################################
6
7 RANGER_VERSION = 1.7.2
8 RANGER_SITE = http://ranger.nongnu.org
9 RANGER_SETUP_TYPE = distutils
10 RANGER_LICENSE = GPL-3.0
11 RANGER_LICENSE_FILES = AUTHORS
12
13 # The ranger script request python to be called with -O (optimize generated
14 # bytecode slightly; also PYTHONOPTIMIZE=x). This implicitly requires the python
15 # source files to be present. Therefore, the -O flag is removed when only the .pyc
16 # files are installed.
17
18 define RANGER_DO_NOT_GENERATE_BYTECODE_AT_RUNTIME
19         $(SED) 's%/usr/bin/python -O%/usr/bin/python%g' $(@D)/scripts/ranger
20 endef
21
22 ifeq ($(BR2_PACKAGE_PYTHON3_PYC_ONLY)$(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
23 RANGER_POST_PATCH_HOOKS += RANGER_DO_NOT_GENERATE_BYTECODE_AT_RUNTIME
24 endif
25
26 $(eval $(python-package))