]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/python-gunicorn/python-gunicorn.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / python-gunicorn / python-gunicorn.mk
1 ################################################################################
2 #
3 # python-gunicorn
4 #
5 ################################################################################
6
7 PYTHON_GUNICORN_VERSION = 19.6.0
8 PYTHON_GUNICORN_SOURCE = gunicorn-$(PYTHON_GUNICORN_VERSION).tar.gz
9 PYTHON_GUNICORN_SITE = https://pypi.python.org/packages/84/ce/7ea5396efad1cef682bbc4068e72a0276341d9d9d0f501da609fab9fcb80
10 PYTHON_GUNICORN_SETUP_TYPE = setuptools
11 PYTHON_GUNICORN_LICENSE = MIT
12 PYTHON_GUNICORN_LICENSE_FILES = LICENSE
13
14 # At the end of the build, we try to compile all py files using the host python
15 # that has been built.
16 # The GAIO HTTP Worker is only compatible with Python3.4.2 and up. So don't try
17 # to compile it with python 2.x
18 ifeq ($(BR2_PACKAGE_PYTHON),y)
19 define PYTHON_GUNICORN_REMOVE_GAIO_WORKER
20         find $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages/ \
21                 -name "_gaiohttp.py" -exec rm -f {} \;
22 endef
23 PYTHON_GUNICORN_POST_INSTALL_TARGET_HOOKS += PYTHON_GUNICORN_REMOVE_GAIO_WORKER
24 endif
25
26 $(eval $(python-package))