]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/php-ssh2/php-ssh2.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / php-ssh2 / php-ssh2.mk
1 ################################################################################
2 #
3 # php-ssh2
4 #
5 ################################################################################
6
7 PHP_SSH2_VERSION = 1.1.2
8 PHP_SSH2_SOURCE = ssh2-$(PHP_SSH2_VERSION).tgz
9 PHP_SSH2_SITE = https://pecl.php.net/get
10 PHP_SSH2_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
11         --with-ssh2=$(STAGING_DIR)/usr
12 # phpize does the autoconf magic
13 PHP_SSH2_DEPENDENCIES = libssh2 php host-autoconf
14 PHP_SSH2_LICENSE = PHP-3.01
15 PHP_SSH2_LICENSE_FILES = LICENSE
16
17 define PHP_SSH2_PHPIZE
18         (cd $(@D); \
19                 PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
20                 PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
21                 $(STAGING_DIR)/usr/bin/phpize)
22 endef
23
24 PHP_SSH2_PRE_CONFIGURE_HOOKS += PHP_SSH2_PHPIZE
25
26 $(eval $(autotools-package))