]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/openobex/openobex.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / openobex / openobex.mk
1 ################################################################################
2 #
3 # openobex
4 #
5 ################################################################################
6
7 OPENOBEX_VERSION = 1.7.2
8 OPENOBEX_SITE = http://downloads.sourceforge.net/project/openobex/openobex/$(OPENOBEX_VERSION)
9 OPENOBEX_SOURCE = openobex-$(OPENOBEX_VERSION)-Source.tar.gz
10 # Libraries seems to be released under LGPL-2.1+,
11 # while other material is under GPL-2.0+.
12 OPENOBEX_LICENSE = GPL-2.0+/LGPL-2.1+
13 OPENOBEX_LICENSE_FILES = COPYING COPYING.LIB
14 OPENOBEX_DEPENDENCIES = host-pkgconf
15 OPENOBEX_INSTALL_STAGING = YES
16 OPENOBEX_CONF_OPTS = -DBUILD_DOCUMENTATION=OFF
17
18 ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
19 OPENOBEX_DEPENDENCIES += bluez_utils
20 endif
21
22 ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
23 OPENOBEX_DEPENDENCIES += bluez5_utils
24 endif
25
26 ifeq ($(BR2_PACKAGE_LIBUSB),y)
27 OPENOBEX_DEPENDENCIES += libusb
28 endif
29
30 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
31 OPENOBEX_DEPENDENCIES += udev
32 endif
33
34 $(eval $(cmake-package))