]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/libsrtp/libsrtp.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / libsrtp / libsrtp.mk
1 ################################################################################
2 #
3 # libsrtp
4 #
5 ################################################################################
6
7 LIBSRTP_VERSION = v1.5.4
8 LIBSRTP_SITE = $(call github,cisco,libsrtp,$(LIBSRTP_VERSION))
9 LIBSRTP_INSTALL_STAGING = YES
10 LIBSRTP_LICENSE = BSD-3-Clause
11 LIBSRTP_LICENSE_FILES = LICENSE
12
13 ifeq ($(BR2_STATIC_LIBS),y)
14 LIBSRTP_MAKE_OPTS = libsrtp.a
15 else ifeq ($(BR2_SHARED_LIBS),y)
16 LIBSRTP_MAKE_OPTS = shared_library
17 else
18 LIBSRTP_MAKE_OPTS = libsrtp.a shared_library
19 endif
20
21 # While libsrtp is not using pkg-config itself, it checks if
22 # pkg-config is available to determine whether it should install
23 # libsrtp.pc. Since installing it seems useful, let's depend on
24 # host-pkgconf to make sure pkg-config is installed.
25 LIBSRTP_DEPENDENCIES = host-pkgconf
26
27 # openssl handling needs libdl support
28 ifeq ($(BR2_PACKAGE_OPENSSL)x$(BR2_STATIC_LIBS),yx)
29 LIBSRTP_DEPENDENCIES += openssl
30 LIBSRTP_CONF_OPTS += --enable-openssl
31 else
32 LIBSRTP_CONF_OPTS += --disable-openssl
33 endif
34
35 $(eval $(autotools-package))