]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/libsoil/libsoil.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / libsoil / libsoil.mk
1 ################################################################################
2 #
3 # libsoil
4 #
5 ################################################################################
6
7 LIBSOIL_VERSION = 20080707
8 LIBSOIL_SOURCE = soil.zip
9 LIBSOIL_SITE = http://www.lonesock.net/files
10 LIBSOIL_INSTALL_STAGING = YES
11 LIBSOIL_DEPENDENCIES = libgl
12 LIBSOIL_LICENSE = Public Domain, MIT
13 LIBSOIL_LICENSE_FILES = src/stb_image_aug.c src/image_helper.c
14 LIBSOIL_MAKEFILE = ../projects/makefile/alternate_Makefile.txt
15
16 define LIBSOIL_EXTRACT_CMDS
17         $(UNZIP) -d $(@D) $(LIBSOIL_DL_DIR)/$(LIBSOIL_SOURCE)
18         mv $(@D)/Simple\ OpenGL\ Image\ Library/* $(@D)
19 endef
20
21 # gnu patch < v2.5.9 doesn't correctly handle spaces in file names,
22 # and we want to patch the 'alternate Makefile.txt' file, so rename
23 # the file (and patch the renamed file) for compatibility with older
24 # distributions
25 define REMOVE_SPACE_FROM_FILENAME
26         cd $(@D)/projects/makefile/ && \
27                 mv "alternate Makefile.txt" alternate_Makefile.txt
28 endef
29 LIBSOIL_POST_EXTRACT_HOOKS += REMOVE_SPACE_FROM_FILENAME
30
31 define LIBSOIL_BUILD_CMDS
32         $(MAKE) $(TARGET_CONFIGURE_OPTS) -f $(LIBSOIL_MAKEFILE) \
33                 -C $(@D)/src
34 endef
35
36 define LIBSOIL_INSTALL_STAGING_CMDS
37         $(MAKE) $(TARGET_CONFIGURE_OPTS) -f $(LIBSOIL_MAKEFILE) \
38                 DESTDIR=$(STAGING_DIR) install \
39                 INSTALL=$(INSTALL) \
40                 -C $(@D)/src
41 endef
42
43 define LIBSOIL_INSTALL_TARGET_CMDS
44         $(MAKE) $(TARGET_CONFIGURE_OPTS) -f $(LIBSOIL_MAKEFILE) \
45                 DESTDIR=$(TARGET_DIR) install \
46                 INSTALL=$(INSTALL) \
47                 -C $(@D)/src
48 endef
49
50 $(eval $(generic-package))