]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/libsecret/libsecret.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / libsecret / libsecret.mk
1 ################################################################################
2 #
3 # libsecret
4 #
5 ################################################################################
6
7 LIBSECRET_VERSION_MAJOR = 0.18
8 LIBSECRET_VERSION = $(LIBSECRET_VERSION_MAJOR).5
9 LIBSECRET_SITE = http://ftp.gnome.org/pub/GNOME/sources/libsecret/$(LIBSECRET_VERSION_MAJOR)
10 LIBSECRET_SOURCE = libsecret-$(LIBSECRET_VERSION).tar.xz
11 LIBSECRET_INSTALL_STAGING = YES
12 LIBSECRET_DEPENDENCIES = libglib2 host-intltool
13 LIBSECRET_CONF_OPTS = \
14         --disable-manpages \
15         --disable-strict \
16         --disable-coverage \
17         --enable-introspection=no \
18         --enable-vala=no
19 LIBSECRET_LICENSE = LGPL-2.1+
20 LIBSECRET_LICENSE_FILES = COPYING
21
22 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
23 LIBSECRET_DEPENDENCIES += libgcrypt
24 LIBSECRET_CONF_OPTS += --enable-gcrypt \
25         --with-libgcrypt-prefix=$(STAGING_DIR)/usr
26 else
27 LIBSECRET_CONF_OPTS += --disable-gcrypt
28 endif
29
30 $(eval $(autotools-package))