]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/libpthsem/libpthsem.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / libpthsem / libpthsem.mk
1 ################################################################################
2 #
3 # libpthsem
4 #
5 ################################################################################
6
7 LIBPTHSEM_VERSION = 2.0.8
8 LIBPTHSEM_SOURCE = pthsem_$(LIBPTHSEM_VERSION).tar.gz
9 LIBPTHSEM_SITE = http://www.auto.tuwien.ac.at/~mkoegler/pth
10 LIBPTHSEM_LICENSE = LGPL-2.1+
11 LIBPTHSEM_LICENSE_FILES = COPYING
12 LIBPTHSEM_AUTORECONF = YES
13 LIBPTHSEM_INSTALL_STAGING = YES
14 LIBPTHSEM_CONFIG_SCRIPTS = pthsem-config
15
16 # Force the setjmp/longjmp detection, because the test being done in
17 # the AC_CHECK_SJLJ macro is not cross-compilation safe: it checks the
18 # running kernel with 'uname -r', and checks the C library version by
19 # looking at /usr/include/features.h. In terms of kernel version, it
20 # assumes any version later than 2.2.x is fine, except that it doesn't
21 # recognize 4.x as a valid kernel version, recognizing such systems as
22 # "braindead" and therefore falling back to the 'sjljlx' value for
23 # ac_cv_check_sjlj. In terms of C library version, it wants
24 # __GLIBC_MINOR to be at least 1. Since both conditions are true for
25 # all Buildroot systems, we can simply force the setjmp/longjmp
26 # detection to ssjlj.
27 LIBPTHSEM_CONF_ENV += \
28         ac_cv_check_sjlj=ssjlj
29
30 ifeq ($(BR2_PACKAGE_LIBPTHSEM_COMPAT),y)
31 LIBPTHSEM_CONF_OPTS += --enable-compat
32 LIBPTHSEM_CONFIG_SCRIPTS += pth-config
33 else
34 LIBPTHSEM_CONF_OPTS += --disable-compat
35 endif
36
37 $(eval $(autotools-package))