]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/ipmiutil/ipmiutil.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / ipmiutil / ipmiutil.mk
1 ################################################################################
2 #
3 # ipmiutil
4 #
5 ################################################################################
6
7 IPMIUTIL_VERSION = 2.9.9
8 IPMIUTIL_SITE = http://sourceforge.net/projects/ipmiutil/files
9 IPMIUTIL_LICENSE = BSD-3-Clause
10 IPMIUTIL_LICENSE_FILES = COPYING
11 # We're patching configure.ac
12 IPMIUTIL_AUTORECONF = YES
13
14 IPMIUTIL_MAKE = $(MAKE1)
15
16 # forgets to link against libcrypto dependencies breaking static link
17 ifeq ($(BR2_PACKAGE_OPENSSL)x$(BR2_STATIC_LIBS),yx)
18 # tests against distro libcrypto so it might get a false positive when
19 # the openssl version is old, so force it off
20 # SKIP_MD2 can be used only if ALLOW_GNU is defined.
21 IPMIUTIL_CONF_OPTS += CPPFLAGS="$(TARGET_CPPFLAGS) -DALLOW_GNU -DSKIP_MD2"
22 IPMIUTIL_DEPENDENCIES += openssl
23 else
24 IPMIUTIL_CONF_OPTS += --disable-lanplus
25 endif
26
27 $(eval $(autotools-package))