]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/gupnp-tools/gupnp-tools.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / gupnp-tools / gupnp-tools.mk
1 ################################################################################
2 #
3 # gupnp-tools
4 #
5 ################################################################################
6
7 GUPNP_TOOLS_VERSION_MAJOR = 0.8
8 GUPNP_TOOLS_VERSION = $(GUPNP_TOOLS_VERSION_MAJOR).14
9 GUPNP_TOOLS_SOURCE = gupnp-tools-$(GUPNP_TOOLS_VERSION).tar.xz
10 GUPNP_TOOLS_SITE = \
11         http://ftp.gnome.org/pub/gnome/sources/gupnp-tools/$(GUPNP_TOOLS_VERSION_MAJOR)
12 GUPNP_TOOLS_LICENSE = GPL-2.0+
13 GUPNP_TOOLS_LICENSE_FILES = COPYING
14 GUPNP_TOOLS_INSTALL_STAGING = YES
15 GUPNP_TOOLS_DEPENDENCIES = \
16         host-pkgconf \
17         libglib2 \
18         libxml2 \
19         gssdp \
20         gupnp \
21         libsoup \
22         libgtk3
23
24 ifeq ($(BR2_PACKAGE_GUPNP_AV),y)
25 GUPNP_TOOLS_CONF_OPTS += --with-av
26 GUPNP_TOOLS_DEPENDENCIES += gupnp-av
27 else
28 GUPNP_TOOLS_CONF_OPTS += --without-av
29 endif
30
31 ifeq ($(BR2_PACKAGE_GTKSOURCEVIEW),y)
32 GUPNP_TOOLS_DEPENDENCIES += gtksourceview
33 endif
34
35 $(eval $(autotools-package))