]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/fftw/fftw.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / fftw / fftw.mk
1 ################################################################################
2 #
3 # fftw
4 #
5 ################################################################################
6
7 FFTW_VERSION = 3.3.7
8 FFTW_SITE = http://www.fftw.org
9 FFTW_INSTALL_STAGING = YES
10 FFTW_LICENSE = GPL-2.0+
11 FFTW_LICENSE_FILES = COPYING
12
13 # fortran support only enables generation and installation of fortran sources
14 ifeq ($(BR2_TOOLCHAIN_HAS_FORTRAN),y)
15 FFTW_CONF_OPTS += --enable-fortran
16 FFTW_CONF_ENV += FLIBS="-lgfortran -lm"
17 else
18 FFTW_CONF_OPTS += --disable-fortran
19 endif
20
21 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_SINGLE),--enable,--disable)-single
22 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE),--enable,--disable)-long-double
23 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_QUAD),--enable,--disable)-quad-precision
24
25 FFTW_CFLAGS = $(TARGET_CFLAGS)
26 ifeq ($(BR2_PACKAGE_FFTW_FAST),y)
27 FFTW_CFLAGS += -O3 -ffast-math
28 endif
29
30 # x86 optimisations
31 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_USE_SSE),--enable,--disable)-sse
32 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_USE_SSE2),--enable,--disable)-sse2
33
34 # ARM optimisations
35 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_USE_NEON),--enable,--disable)-neon
36 FFTW_CFLAGS += $(if $(BR2_PACKAGE_FFTW_USE_NEON),-mfpu=neon)
37
38 # Generic optimisations
39 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
40 FFTW_CONF_OPTS += --enable-threads
41 FFTW_CONF_OPTS += $(if $(BR2_GCC_ENABLE_OPENMP),--without,--with)-combined-threads
42 else
43 FFTW_CONF_OPTS += --disable-threads
44 endif
45 FFTW_CONF_OPTS += $(if $(BR2_GCC_ENABLE_OPENMP),--enable,--disable)-openmp
46
47 FFTW_CONF_OPTS += CFLAGS="$(FFTW_CFLAGS)"
48
49 $(eval $(autotools-package))