]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/daemon/daemon.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / daemon / daemon.mk
1 ################################################################################
2 #
3 # daemon
4 #
5 ################################################################################
6
7 DAEMON_VERSION = 0.6.4
8 DAEMON_SITE = http://libslack.org/daemon/download
9 DAEMON_LICENSE = GPL-2.0+
10 DAEMON_LICENSE_FILES = LICENSE
11
12 define DAEMON_CONFIGURE_CMDS
13         (cd $(@D); ./config)
14 endef
15
16 define DAEMON_BUILD_CMDS
17         $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) ready
18         $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
19 endef
20
21 define DAEMON_INSTALL_TARGET_CMDS
22         $(TARGET_MAKE_ENV) DEB_BUILD_OPTIONS=nostrip \
23                 $(MAKE) PREFIX=$(TARGET_DIR)/usr -C $(@D) \
24                 install-daemon-bin
25 endef
26
27 $(eval $(generic-package))