]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/assimp/assimp.mk
lrzsz: install symlinks for XMODEM and YMODEM
[coffee/buildroot.git] / package / assimp / assimp.mk
1 ################################################################################
2 #
3 # assimp
4 #
5 ################################################################################
6
7 ASSIMP_VERSION = v3.2
8 ASSIMP_SITE = $(call github,assimp,assimp,$(ASSIMP_VERSION))
9 ASSIMP_LICENSE = BSD-3-Clause
10 ASSIMP_LICENSE_FILES = LICENSE
11 ASSIMP_DEPENDENCIES = zlib
12 ASSIMP_INSTALL_STAGING = YES
13
14 # relocation truncated to fit: R_68K_GOT16O
15 ifeq ($(BR2_m68k),y)
16 ASSIMP_CXXFLAGS += -mxgot
17 endif
18
19 # workaround SuperH compiler failure when static linking (i.e -fPIC is
20 # not passed) in gcc versions 5.x or older. The -Os optimization level
21 # causes a "unable to find a register to spill in class
22 # ‘GENERAL_REGS’" error. -O2 works fine.
23 ifeq ($(BR2_sh):$(BR2_STATIC_LIBS):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),y:y:)
24 ASSIMP_CXXFLAGS += -O2
25 endif
26
27 ASSIMP_CONF_OPTS += -DASSIMP_BUILD_TESTS=OFF \
28         -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) $(ASSIMP_CXXFLAGS)"
29
30 $(eval $(cmake-package))