]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/ipsec-tools/ipsec-tools.mk
ipsec-tools: rename options to have proper prefix
[coffee/buildroot.git] / package / ipsec-tools / ipsec-tools.mk
1 ################################################################################
2 #
3 # ipsec-tools
4 #
5 ################################################################################
6
7 IPSEC_TOOLS_VERSION = 0.8.2
8 IPSEC_TOOLS_SOURCE = ipsec-tools-$(IPSEC_TOOLS_VERSION).tar.bz2
9 IPSEC_TOOLS_SITE = http://sourceforge.net/projects/ipsec-tools/files/ipsec-tools/$(IPSEC_TOOLS_VERSION)
10 IPSEC_TOOLS_INSTALL_STAGING = YES
11 IPSEC_TOOLS_MAKE = $(MAKE1)
12 IPSEC_TOOLS_DEPENDENCIES = openssl flex host-flex
13 # we patch configure.ac
14 IPSEC_TOOLS_AUTORECONF = YES
15
16 # configure hardcodes -Werror, so override CFLAGS on make invocation
17 IPSEC_TOOLS_MAKE_OPTS = CFLAGS='$(TARGET_CFLAGS)'
18
19 # openssl uses zlib, so we need to explicitly link with it when static
20 ifeq ($(BR2_STATIC_LIBS),y)
21 IPSEC_TOOLS_CONF_ENV += LIBS=-lz
22 endif
23
24 IPSEC_TOOLS_CONF_OPTS = \
25           --without-libpam \
26           --disable-gssapi \
27           --with-kernel-headers=$(STAGING_DIR)/usr/include
28
29 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_ADMINPORT),y)
30 IPSEC_TOOLS_CONF_OPTS += --enable-adminport
31 else
32 IPSEC_TOOLS_CONF_OPTS += --disable-adminport
33 endif
34
35 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_NATT),y)
36 IPSEC_TOOLS_CONF_OPTS += --enable-natt
37 else
38 IPSEC_TOOLS_CONF_OPTS += --disable-natt
39 endif
40
41 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_FRAG),y)
42 IPSEC_TOOLS_CONF_OPTS += --enable-frag
43 else
44 IPSEC_TOOLS_CONF_OPTS += --disable-frag
45 endif
46
47 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_DPD),y)
48 IPSEC_TOOLS_CONF_OPTS += --enable-dpd
49 else
50 IPSEC_TOOLS_CONF_OPTS += --disable-dpd
51 endif
52
53 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_STATS),y)
54 IPSEC_TOOLS_CONF_OPTS += --enable-stats
55 else
56 IPSEC_TOOLS_CONF_OPTS += --disable-stats
57 endif
58
59 ifneq ($(BR2_PACKAGE_IPSEC_TOOLS_READLINE),y)
60 IPSEC_TOOLS_CONF_OPTS += --without-readline
61 else
62 IPSEC_TOOLS_DEPENDENCIES += readline
63 endif
64
65 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_HYBRID),y)
66 IPSEC_TOOLS_CONF_OPTS += --enable-hybrid
67 else
68 IPSEC_TOOLS_CONF_OPTS += --disable-hybrid
69 endif
70
71 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_SECCTX_DISABLE),y)
72 IPSEC_TOOLS_CONF_OPTS += --enable-security-context=no
73 endif
74 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_SECCTX_ENABLE),y)
75 IPSEC_TOOLS_CONF_OPTS += --enable-security-context=yes
76 endif
77 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_SECCTX_KERNEL),y)
78 IPSEC_TOOLS_CONF_OPTS += --enable-security-context=kernel
79 endif
80
81 $(eval $(autotools-package))