]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/monit/monit.mk
monit: bump version to 5.6
[coffee/buildroot.git] / package / monit / monit.mk
1 ################################################################################
2 #
3 # monit
4 #
5 ################################################################################
6
7 MONIT_VERSION = 5.6
8 MONIT_SITE = http://mmonit.com/monit/dist/
9 MONIT_LICENSE = AGPLv3 with OpenSSL exception
10 MONIT_LICENSE_FILES = COPYING
11
12 MONIT_CONF_ENV = \
13         libmonit_cv_setjmp_available=yes \
14         libmonit_cv_vsnprintf_c99_conformant=yes
15
16 MONIT_CONF_OPT += \
17         --without-pam
18
19 ifeq ($(BR2_PACKAGE_OPENSSL),y)
20 MONIT_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr
21 MONIT_DEPENDENCIES += openssl
22 else
23 MONIT_CONF_OPT += --without-ssl
24 endif
25
26 ifeq ($(BR2_LARGEFILE),y)
27 MONIT_CONF_OPT += --with-largefiles
28 else
29 MONIT_CONF_OPT += --without-largefiles
30 endif
31
32 $(eval $(autotools-package))